• New from wisconsin:

November 2019 Forum Retirement
Due to lack of extra personal time (and too much spam), I'm retiring the forum and setting it to a read-only state. No new registrations or posts will be accepted as of 11/09/19. However, all information will stay up and searchable. If you spend a few minutes searching, you'll find the answers you're looking for. We may re-open the forum next spring.
 #7953  by JaceMullen
 Fri May 21, 2010 3:44 pm
Hey my name is Jace Mullen. I am new to this form. The main place I go is buggynews. But said why not try another one. I ride a 200cc Blade buggy. I bought it used and with the help of 6 friends from another forum I got her up and running. I do not have the money for the parts and they gave me what I needed for no charge. Thanks to them I have a like new buggy. Pictures below.
Attachments
0519101228.jpg
The engine harbor, all covers and plastic is flat black along with all the wires and battery. The exhaust is also flat black
0519101228b.jpg
The engine harbor, all covers and plastic is flat black along with all the wires and battery.
0518102025.jpg
This is before
 #7954  by JaceMullen
 Fri May 21, 2010 3:47 pm
Pictures
Attachments
0520101545.jpg
Hoped stands for, Headman, olderthan, panzer, djmac, the where the usernames that gave me all the parts I need to get my buggy up and running
 #7955  by PGH
 Fri May 21, 2010 4:41 pm
I thought that was EJMAC and DIGGER on the end?

Welcome to Buggy Depot.
 #7957  by JaceMullen
 Fri May 21, 2010 4:45 pm
haha tell you the truth I can't always remember the usernames. It is Ejmac, and digger, panzer, olderthan, and headman. There we go :) i see a lot of the guy are on here to. It is like the same interface.
 #7961  by olderthan
 Fri May 21, 2010 8:05 pm
hi jace