• GY6 Fire, Won't Start

  • Have a technical problem? Ask here.
November 2019 Forum Retirement
Due to lack of extra personal time (and too much spam), I'm retiring the forum and setting it to a read-only state. No new registrations or posts will be accepted as of 11/09/19. However, all information will stay up and searchable. If you spend a few minutes searching, you'll find the answers you're looking for. We may re-open the forum next spring.
Have a technical problem? Ask here.
Forum rules: Help us to help you, by reading our information in this Forum thoroughly and performing the tests within to pinpoint your issue.
 #13665  by Rotorooster
 Wed Jun 19, 2019 10:01 pm
I recently purchased a Maxxam 150 2R for my kids. It is cranking great and even firing, but wont start.

I replaced the carburetor, CDI, plug, ignition wire, fuel filter, air filter, and petcock. The plug is getting great spark, fuel seems to be flowing..... what could it be?

I got lucky and it started up for me, I took it for a nice ride. 99% of the time, it turns over, cranks nice, "fires" like it wants to start every 5 -6 cranks, but won't quite do it. I'm at my whits end. Is it electrical? Internal? Do I need to make any initial adjustments to the carb? When I got it running (one lucky time), i adjusted the idle screw and it would stay running all day long. It just won't start!

Any advice is greatly appreciated.
 #13667  by Jim_36_decker
 Sat Jun 22, 2019 7:58 pm
I need help I just bought a 2004 twister hammer head go kart that I can not figure out the wiring for the ignition or kill switch I can get it to turn over from the cylinoid but I have no kill switch or ignition just wires please help (y)