• KD150FS problems

  • Have a technical problem? Ask here.

    READ THE SECTION RULES BEFORE POSTING FOR HELP
Have a technical problem? Ask here.

READ THE SECTION RULES BEFORE POSTING FOR HELP
Forum rules: Help us to help you, by reading our information in this Forum thoroughly and performing the tests within to pinpoint your issue.
 #13360  by kandirider
 Mon Apr 01, 2019 1:46 pm
Hey all, I'm fairly new to this forum, so forgive me if I'm posting a question that's already been answered. I have a KD150FS, that has just had a whole new top end installed (valves, cylinder and head), and a brand new Japanese Keihin carb. It started up, ran fine for an hour or two, but now, it won't idle, only runs with some gas on, and is very sluggish and wants to bog slightly under acceleration. It also makes small popping noises (not backfires) when on the throttle. I think this can be traced back to the carb, but I'm new to this and don't know where to start. It does have a UNI filter on it instead of the stock airbox, so it may be I'm running lean and need to rejet, but what stumps me is why it ran perfectly before this for a while. I had the idle screw set where it would idle fine, and now it won't. I also have messed with the mixture screw, and it doesn't seem to run any better set way rich. It did sit out once on a 25* or so night once, but that really shouldn't affect much, should it? Please help!
 #13408  by motohead342
 Fri Apr 19, 2019 3:48 am
The Pilot/Idle Jet is clogged. Remove, clean out,... or replace with a 38, it'll start and idle better. And a 125 to 140 Main when you replace the stock airbox and paper filter with a free flowing FOAM FILTER. Get a can of Berrymans Chemtool. It'll help with the job,... alot.
 #13409  by kandirider
 Fri Apr 19, 2019 3:14 pm
Well, I think that I am too small on the jets, since I have an UNI filter on. It has a brand new Keihin carb. I will try what you said and see what happens. Also, where would you get new jets from?